Chapter 1: C++, SFML, Visual Studio, and Starting the First
Game
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Visual Studio 2019

Code faster. Work smarter. Create the future with the best-in-class IDE.

x;, Download Visual Studio v

Community 2019

Professional 2019

m  Tools Test Analyze Window Help Enterprise 2019 i
P Attach.. ~ 5

Visual Studio Installer

Before you get started, we need to set up a few things so that you
can configure your installation.

To learn more about privacy, see the Microsoft Privacy Statement.

By continuing, you agree to the Microsoft Software License Terms.

Installing — Visual Studie Community 2019 — 16.0.2 X
Workloads Individual components Language packs Installation locations
HEEETE Installation details
O 0 v Visual Studio core editor
ASPNET and web development I Azure development -
y ’ § s The Visual Studio core shell experience, including syntax-
Build web applications using ASP.NET, ASP.NET Core, Azure SDKs, tools, and projects for developing cloud apps, O T I G D TR T 3
HTML/JavaScript, and Containers including Docker support. creating resources, and building Containers including....
management.
Python development O @ Node.js development O
t.‘ Editing, debugging, interactive development and source Build scalable network applications using Node s, an
control for Python. asynchronous event-driven JavaSeript runtime.
Windows (3)
.NET desktop development D b Desktop development with C++ D
'—.-.J Build WPF, Windows Forms, and console applications using Build Windows desktop applications using the Microsoft
C#, Visual Basic, and F#. C#++ toolset, ATL, or MFC.

Location

C:\Program Files (x86)\Microsoft Visual Studio\2019\Community Change...
Total space required 598 MB.

By continuing, you agree to the license for the Visual Studio edition you selected. We also offer the ability to download other software with Visual Studio. This software is licensed separately,

as set out in the 3rd Party Notices or in its accompanying license. By continuing, you also agree to those licenses. Install while downloading ~ Install




Learn Download Community Development

Home » Download I I Francais & Donate

Download

-

Latest stable version In development versions

SFML 2.5.1 ‘@ Snapshots

| 4

SFML in other languages GitHub.com

Bindings ‘ WJ Git repository

Download SFML 2.5.1

On Windows, choosing 32 or 64-bit libraries should be based on which platform you want to compile for, not which OS you have. Indeed, you can perfectly
compile and run a 32-bit program on a 64-bit Windows. So you'll most likely want to target 32-bit platforms, to have the largest possible audience. Choose

64-bit packages only if you have good reasons.

The compiler versions have to match 100%!
Here are links to the specific MinGW compiler versions used to build the provided packages:

TDM 5.1.0 (32-bit), MinGW Builds 7.3.0 (32-bit), MinGW Builds 7.3.0 (64-bit)

Visual C++ 15 (2017) - 32-bit % Download | 163mB || Visual C++ 15 (2017) - 64-bit Download | 18.0ms
Visual C++ 14 (2015) - 32-bit Download | 18.omB | | Visual C++ 14 (2015) - 64-bit Download | 19.9mB
Visual C++ 12 (2013) - 32-bit Download | 183mB | | Visual C++ 12 (2013) - 64-bit Download | 203 mB

GCC 5.1.0 TDM (SJLJ) - Code::Blocks - 32-bit Download | 14.1 MB

GCC 7.3.0 MinGW (DW2) - 32-bit Download | 15.5MB | | GCC 7.3.0 MinGW (SEH) - 64-bit Download | 16.5MB
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Console App ¢+

Windows

Project name

Timber

Location

D:\VS Projects\

Solution name (@)

Timber

. Place solution and project in the same directory

Console

Configure your new project

Back

Create
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b Fle Edt View Project Buld Debug Test Analyze Tools Extensions Window  Help | Search Visual Studio (Cirli()

0~ B-m A 2-C-

P Timber

Debug ~ %86 - P Local Windows Debugger ~ 5% _ - 3 ER RN B I

]

Solution Explorer =

- (Global Scope) |
£/ Timber.cpp : This file contains the 'main’ function. Program execution begins and ends there.
/"

#include <iostreams
Eint main()

std::cout << "Hello World!\n";

}

E// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
[ 7/ Debug program: F5 or Debug > Start Debugging menu

El// Tips for Getting Started:
// 1. Use the Solution Explorer window to add/manage files
2. Use the Team Explorer window to connect to source control
3. Use the Output window to see build output and other messages
/! 4. Use the Error List window to view errors
5.
6.

@ No issues tound <

Go to Project > Add New Item to create new code files, or Project > Add Existing Item to add existing code files to the
In the future, to open this project again, go to File > Open > Project and select the .sln file

Search Solution Explorer (Ctrl+))
1] Solution Timber' (1 project)
4 %] Timber

b =8 References

13 External Dependencies
#8 Header Files
8 Resource Files

b Source Files

Solution Explorer | Team Explorer

Properties *

=L

fco@e- o-5 8B o s

- =]
12 Live Share

~ i

NET Target Framework Version
Whole Program Optimization
Windows Store App Support No

b Browse Information Build Log File $(IntDir)$(MSBuildProjectName).log
b Build Events Platform Toolset Visual Studio 2019 (v142)
» Custom Build Step Enable Managed Incremental Build No
> Code Analysis AgErojectiDeraults
Configuration Type Application (.exe)
Use of MFC Use Standard Windows Libraries
Character Set Use Unicode Character Set
Common Language Runtime Support No Common Language Runtime Support

No Whole Program Optimization

Timber Property Pages ? X
Configuration: |Active(Debug) =2 ‘ Platform: ‘Active(WinSZ) &2 | ‘ Configuration Manager...
4 Configuration Properties v General
General T S - ciov:s 10
Debugging Windows SDK Version 10.0 (latest installed version)
VC++ Directories Output Directory $(SolutionDir)$(Configuration)\
b C/C++ Intermediate Directory $(Configuration)\
1> Linker Target Name $(ProjectName)
> Manifest Tool Target Extension exe
1> XML Document Generator Extensions to Delete on Clean * cdf;*.cache;*.obj;*.obj.enc;*.ilk;*.ipdb;*.iobj;* resources;*.tlb;* tli;* tlh;* tmp;*.rsp;*.pgc;*.pgd;*.m

Target Platform
The current target platform of the project.

"'I ’ Configuration Manager... ]

A

cnnfigurationil Canfigurations * | Platform: |Active(Win32)
4 Configuration Properties Additional Indude Directories
General Additional #using Directories
Debugging Debug Infermation Format
VC++ Directories Common Language RunTime Support
C/CH+ Consume Windows Runtime Extension
GE""_!“_" _ | Suppress Startup Banner
Optimization Warning Level
Pre;rnﬂessur B Treat Warnings As Errors
f: e Generation SDL ched
nguage i _—
; Multi-processor C lati
Precompiled Headers = L

DASFMLnclude

<different options>

Yes (/nologo)
Level3 (YW3)
Mo (MWX-)
Yes (/sd)

3

[=]




4 Configuration Properties
General
Debugging
VC++ Directories
P C/C++

4 Linker 1
General

Input
Manifest File
Debugging
System

Output File
Show Progress
Version

Enable Incremental Linking

Suppress Startup Banner
Ignore Import Library
Register Qutput
Per-user Redirection

No 2
Additional Library Directories D:\SFML\lib

Link Library Dependencies
Use Library Dependency Inputs No

$(OutDir)$(TargetName)$(TargetExt)
Not Set

<different options>
Yes (/NOLOGO)

No

No

Yes

Conﬁguration:kebug

w [ Platform: |Active(Win32)

4 Configuration Properties
General

'] I Configuration Manager... ]

Ignore All Default Libraries

Debugging
VC++ Directories
[» C/C++
4 Linker
General
Input
Manifest File
Debugging
System
Optimization
Embedded IDL
Windows Metadata
Advanced
All Options
Command Line
[> Manifest Tool
[* XML Document Generator
[> Browse Information
[> Build Events
[» Custom Build Step
[» Code Analysis

Ignore Specific Default Libraries
Module Definition File

Add Module to Assembly
Embed Managed Resource File
Force Symbol References

Delay Loaded Dlls

Assembly Link Resource

ernel32.lib;user32.lib;gdi32.lib;winspool.lib;c

dig32.lib;ad ¥ ]

Additional Dependencies
Specifies additional items to add to the link command line. [i.e. kernel32.lib]

Chopped
log

Lethal
branches

Player's current score

Decorative bee

SCORE =42 ¢4

Shrinking time-bar

Decorative floating clouds

Player
Character




4| openal32.dil

. sfml-audio-2.dll

<) sfml-audio-d-2.dll
< sfml-graphics-2.dll
< sfml-graphics-d-2.dll
< sfml-network-2.dll
<) sfml-network-d-2.dll
<) sfml-system-2.dll

<) sfml-system-d-2.dll

2 sfml-window-2.dll

2 sfml-window-d-2.dll

0 fie Edit View Project Buld Debug Test Anayze Tools bitensions Window Help | Search Visual Studio (- P Timber
C-0 | B-m M| 2 -||pebug -|[x6 | P Local Windows Debugger = | B8 _ ke 00| =78 W 9 A Cn
{ IR =
§
o Bl Timber *|  (Global Scope) - =
g 1 )/ Timber.cpp : This file contains the 'main’ function. Program execution begins and ends there.
3 2|
o 3
8 a #include <iostream>
g 5
6  Eint main()
7
8 std::cout << "Hello World!\n";
s )
10
11 B// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
12 J/ Debug program: F5 or Debug > Start Debugging menu .
13
i This-is-where we do our coding
15 /7 717 U%e the solution Explorer window to add/manage files
16 // 2. Use the Team Explorer window to connect to source control
17 // 3. Use the Output window to see build output and other messages
18 // 4. Use the Error List window to view errors
19 // 5. Go to Project > Add New Ttem to create new code files, or Project > Add Existing Ttem to add existing code files to the ¢
20 // 6. In the future, to open this project again, go to File > Open > Project and select the .sln file
21
100% ~ @ Noissues found “ »

& Live Share &

Solution Explorer 0%
CO@ME-|®
Search Solution Explorer (Ctrl+;)

5 solution “Timber (1 project)
4 &) Timber

b ®8 References

b M@ External Dependencies

olation Ex

8 Source Files

Solution Explorer | Team Explorer

Properties
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540 -
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Internal Coordinates
(Origin = 0, 0)

y=0

increasing values of x ——>

£ jo sanjeA buiseaioul

P Local Windows Debugger - |

Update all the game objects
{move them, see if they collided,
Al, etc.)

Respond to any screen touches Draw all the game objects in there
from the user up-to-date positions







Chapter 2: Variables, Operators, and Decisions —
Animating Sprites




Chapter 3: C++ Strings and SFML Time — Player Input and
HUD

PRESS ENTER TO%

SCOKE = O




OUT OF TIME!.‘“

Chapter 4: Loops, Arrays, Switches, Enumerations, and
Functions — Implementing Game Mechanics

SCORE = O
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Chapter 5: Collisions, Sound, and End Conditions —
Making the Game Playable
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Chapter 6: Object-Oriented Programming — Starting the
Pong Game

Chapter 7: Dynamic Collision Detection and Physics —
Finishing the Pong Game




Chapter 8: SFML Views — Starting the Zombie Shooter
Game

SCORE;220 g " i L SCORE:340

ammo_icon ammo_pickup background background_shee
t

A w 6 =

bloater blood chaser

/.If ~

crosshair health_pickup player

// The main game loop
while (window.isOpen())

{




ChapterSZDmbie Arena vI (Global Scope) '|® main()
Flint main()
{

// The game will always be in one of four states

enum class State { PAUSED, LEVELLING UP, GAME OVER, PLAYING };
// Start with the GAME_OVER state

State state = State::GAME_OVER;

// Get the screen resolution and create an SEMI window

Vector2f reseclution; . Quick Actions... Ctrl+.
resolution.x = VideoMode: : getDesk E1 Rename. Ctri+R, R
resolution.y = VideoMode: : getDesH
%1 Surround With. Ctrl+K, S
Renderbiindow window(Videollode(red % Go To Definition iz
"Zombie Arena", Style::Fulls. X
= Go To Declaration Ctrl+Alt+F12
// Create a an SFML View for the Find All References Ctrl+K, R
View mainView(sf::FloatRect(®, @) T viewCall Hierarchy Ctrl+K, Ctrl+T
Toggle Header / Code File Ctrl+K, Ctrl+O

// Here is our clock for timing ¢
Clock clock; Breakpoint »
How long has the PLAYING state
/'.I B X RunTo Cursor Ctrl+F10
Time gameTimeTotal;

Run Flagged Threads To Cursor

// Where is the mouse in relatiorn % Cut Ctrl+X

Vector2f mouseWorldPosition; o

// Where is the mouse in relatior| ¥ Copy Lk

Vector2?i mouseScreenPosition; g1 Paste Cirl+V

Outlinin 3 i i

// Create an instance of the Pla ) Hide Selection Ctrl+M, Ctrl+H

Player player; Toggle Outlining Expansion Ctrl+M, M
Toggle All Outlining Ctrl+M, L

/{ The boundaries of the arena .

T ge— Stop Outlining Ctrl+M, P
Stop Hiding Current Ctrl+M, Ctrl+U

// The main game loop Collapse to Definitions Ctrl+M, O

= while (window.isOpen(})

—int main()
{

+ |

// The main game loop
= while (window.isOpen())
{




Chapter 9: C++ References, Sprite Sheets, and Vertex
Arrays

0,0 to
49, 49
0,50 to
49, 99
0,100 to
49, 149
0, 150 to
49, 199




Chapter 10: Pointers, the Standard Template Library, and

Texture Management
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L
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Chapter 12: Layering Views and Implementing the HUD

SCORE:Q Hi SCORE:Q

WAVE:Q  ZOMRIES:10

H\ SCORE:0

PRESS ENTER T PLAY




P —

T~ INGREASER RATE OF FIR

&~ INGREASED GLIP SIZECNE BAR)
- INCREASER MAX HEALTH

Y- INGREASED RUN SPEER

> MORE AND BETTER HEALTH PIGKUPS
G~ MORE ANR BETTER AMMBD PICKUPS

Hi SGORE:Q

WAVE: 0 ZOMRIES: 100




SCORE:Q Hi SCORE:300

WAVE:1  ZOMBIES:S
Chapter 13: Sound Effects, File I/O, and Finishing the
Game
SCORE:300 o e iy . W SCORE:310

) 7%
ol oo T

3

__WAVEM  ZOMBIES:20




Chapter 14: Abstraction and Code Management — Making
Better Use of OOP

_HUD-__

"Molten" effect
background

v qu

} v

Particle ' | Thomas

Effect _ |
Fire & Water

- .

Split screen coop

Level:]




Level:T

Level:]




Level:T

background bob thomas tiles_sheet
Input.cpp
Engine::input()
{
Engine.h : // All the input code
_ Englne.cpp )
private: Engine::run()
input() {
update() input(); U ]
draw() update(); pdate PP
draw(); Engine::update()
public: } {
run(),/ \ /[ All the updating code
¥

Draw.cpp

Engine::draw()

// All the drawing code
¥




m_ LeftView
on top of
m_ BGLeftView

m_RightView
on top of

m_BGRightView

File Edit View Project Builld Debug Team
'3' |iﬁaun“‘9' "Debug-

Input.cpp Update.cpp Draw.cpp + X

%] Chapter 12 TWL
sl#include "stdafx.h"

#include "Engine.h"

—void Engine::draw()

Tools Test Window  Help

86

= P Local Windows Debugger ~

* | = Engine




Chapter 15: Advanced OOP - Inheritance and

Polymorphism

m_Feet

m__H ead

~m_Right







Chapter 16: Building Playable Levels and Collision
Detection
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Chapter 18: Particle Systems and Shaders







Chapter 19: Game Programming Design Patterns — Starting
the Space Invaders ++ Game

Score.9 Lives: 3 Wave: 1

Score.9 Lives: 0 Wave: 1

lay | Home

GAME OVER! .

=




Screen

View m_View

update()
draw() ,

vector<UIPanel> m_Panels
vector<inputHandler> m_Handlers

handleinput() ~__

""H-»._\.

.

~—

UlPanell

vector<Buttons>m_Buttons
View m_ View

draw()

InputHandlerl

vector<Buttons>m_Buttons

View m_ View

handlelnput()

UlPanel2

vector<Buttons>m_Buttons
View m_ View

draw()

InputHandler2

vector<Buttons>m_Buttons

handlelnput()

GameEngine

ScreenManager
m_ScreenManager

handlelnput()

A 4

Update()

¥

Draw()

¥

ScreenManager

String m_CurrentScreen = “Select”
map<string, Screen> m_Screens

m_Screens[m_CurrentScreen]->handlelnput()
m_Screens[m_CurrentScreen]->update()

m_Screens[m_CurrentScreen]->draw()

SwitchScreen(string nextScreen)




GameObject

Screen vector<Component>
s
update() | UpdateComponent
// loopth roy_gh_,_allga‘rﬁé'abjects 4
| || GraphicsComponent
[
draw()

ColliderComponent

{

// loop th,_,rougﬁ"{érlrl game objects

I TransformComponent

Solution "Space Invaders ++" (1 of 1 project)

4 [%| Space Invaders ++
P =B References
P m External Dependencies
4 ' Header Files

Engine

FilelO

+ GameObjects

4 . Screens

T

T

Game
M Select
Eesource Files

™

4 Source Files
Engine

FilelO

; GameObjects

4 . Screens

"

T

Game
M Select
P ++ Space Invaders ++.cpp

™




| Quit

SPACE INVADERS ++

Score.0 Lives: 3 Wave: 7847

Score.0 Lives: 3 Wave: 2

~  Home

GAME OVER!




Chapter 21: File I/O and the Game Object Factory

ScreenManager

LevelManager

PlayMode GameObjectFactory
ObjectLoader PlayMode

'

BlueprintObject
Parser

GameObject

Blueprint

Levell.txt




Chapter 22: Game Objects and Building a Game

\
-100, -100

50, -50

100, O
— 0, 50
-100, 1 00, 100
%] Space Invaders ++ 2
1 #include "GameEngine.h"
2
3 -lint main()
4 {
@ 5 GameEngine m_GameEngine;
6 m_GameEngine.run();
7 return 0;
8 H
() 5 | GameEngine m_GameEngine;
6 m_GameEngine.run();

7 return ©;




m_GameEngine;

@
» @ m_Clock {m_startTime={m_microseconds=-3689348814741910324 } }
» @ m_DT {m_microseconds=-3689348814741910324 }
» @ m_Window e
» @ m_ScreenManager unique_ptr {m_Screens={ size=777 } m_LevelManager={m_GameObjects={ size=?7? } WORLD_FOLDER={..} SLASH={..} } ..}
@, m_FPS -107374176.
» @ m_Resolution {x=-107374176. y=-107374176.}

» @ m_SoundEngine {m_ShootBuffer={m_buffer=3435973836 m_samples={ size=0 } m_duration={m_microseconds=-3689348814741910324 ] .} ..}

» Continue ~ 5@ — mo 2|3

=+

|
|
o
27
[
[l]

P Continue ~ 5

» Continue ~ 5@ — E@ 2> b = B

P Continue ~| 5" - B9 =2 8=




